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Einleitung
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 Die Übung soll Ihnen einen Eindruck zu Konzepten zur Präprozessierung von Daten für die 

numerische Grundwassermodellierung mit QGIS vermitteln. 

 2 Übungsteile:  1) Generierung und Prozessierung der Randgeometrien sowie innerer 

Geometrien

2) 2D Vernetzung des Modelliergebietes unter Nutzung des Gmsh Plugins

 Es gibt Videos zu den Übungen (auf Englisch), diese befinden sich hier:

 https://nc.ufz.de/s/9WyZYSokq8Y2q3m (pw: grundwasser)

https://nc.ufz.de/s/9WyZYSokq8Y2q3m


QGIS: Übung 2
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 Ein Grundwasserströmungsmodell für das untere 

Selkegebiet soll erstellt werden, um den Einfluss des 

bewirtschafteten Bergbausees auf die 

Grundwasserdynamik aufzuzeigen

 Aufgaben im GIS

1. Die Domänengrenze (eine geschlossene Polylinie) 

des Modells wird durch die Flüsse Bode und Wipper

bestimmt. Darum hinaus muss die Randbedingung 

im Anstrombereich des Modells geometrisch und 

hydrogeologisch beschrieben werden

2. Die geometrischen Einheiten werden bereinigt 

(regelmäßige Scheitelpunktabstände)

3. Das FEM-Netz wird unter Einbeziehung dieser 

geometrischen Elemente erstellt

Bode

Wipper

750 km²



QGIS: Übung 2

4www.ufz.de

Präprozessierung

Postprozessierung

(Visualization)

Simulation

Wir interpretieren und analysieren die Simulationsergebnisse 

Wir bilden den physikalischen Prozess mit 

mathematischen Methoden nach

Wir abstrahieren das Problem und 

diskretisieren in Raum und die Zeit. 



Prozessierung der Randgeometrien
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 Öffnen Sie ein neues QGIS-Projekt

 Laden Sie alle Shapefiles aus .\U9\Eingabe in das Projekt

 Aktivieren Sie den Bearbeitungsmodus und verwenden Sie das Werkzeug Qchainage (Plugin), um alle 

1000 m Punkte auf die Linien Upstream_Boundary, River_Wipper und River_Bode zu setzen



Prozessierung Polylinien
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 Die Abgrenzung des oberen, durch Kluftaquifere, 

geprägten Einzugsgebiets vom Unterlauf erfolgt 

durch eine Polylinie, die möglichst den Verlauf 

des Harzrandes abbildet

 Annahmen:

1. Alluviale Aquifere sind von vorrangigem 

Interesse für das Modellkonzept

2. Ein Teil der Grundwasserneubildung im 

Unterlauf erfolgt aus dem Kluftaquifer

3. Die Grundwasserfließrichtung entspricht dem 

normalen Vektor entlang der Randbedingung

4. Die Wasserstände von Stauteichen im Harz 

entsprechen ungefähr dem lokalen 

hydraulischen Potential des Kluftaquifers
Alternativer Ansatz: Wolf 2006



Prozessierung der Randgeometrien
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 Wir wandeln die Punkte zurück in Polylinen mit dem Plugin Points to Path



Prozessierung der Randgeometrien
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 Führen wir die 3 Polylinien zusammen

 Klick auf Vector >Data Management Tools > 

Merge Vector Layers 

Ordnen sie die 

Polylinien im 

Uhrzeigersinn 

an



Prozessierung der Randgeometrien
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 Der zusammengefügte Datensatz enthält weiterhin Lücken zwischen den Polylinien,  topologische 

Konnektivität ist aber eine Grundvoraussetzung für den Rand des Modellgebiets

 Aktivieren sie den Editiermodus, nutzen sie das Vertex tool um die Endpunkte näher zusammen zu 

bringen



Prozessierung der Randgeometrien
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 Klicken sie auf Processing >Toolbox Snap geometries to layer

 Falls es nicht funktioniert, bringen sie die Linien näher zusammen mit dem Vertex tool oder erhöhen sie 

die „Snapping“ Toleranz



Prozessierung der Randgeometrien
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 Die Wipper ist ein Nebenfluss der Saale

 Ein Mündungsarm führt zur Bode (die Liethe)

 Für normale Wasserstände ist dieser trocken  Randbedingung?

Liethe

Bode

Saale

Wipper



Export der Randgeometrien
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 Nach der Manipulation der Stützpunkte können 

die Vektorgeometrien extrahiert und exportiert 

werden

 Als Erstes speichern sie die Einzelgeometrien der 

Teilränder

 Wählen sie die den entsprechenden Layer aus 

 Speichern sie als PL_Wipper_1000.shp, 

PL_Bode_1000.shp bzw. PL_Upstream_1000. 

shp im Ausgabe Ordner



Speichern der Modelliergebietsbegrenzungsgeometrie
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 Auflösen der Multipolylinien  VectorGeoprocessing tools Dissolve

 Namen in der Attributtabelle zu „Domain_Bound“ ändern und die Datei als  

PL_Domain_Bound.shp speichern

 Wir haben eine konsistene Randgeometrie für unser numerisches Grundwassermodell!



Modelliergebietsbegrenzungsgeometrie
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 Die geschlossene Polylinie Domain_Bound in ein Polygon überführen:  

Vector > Geometry Tools > Lines to Polygons

 Die Polylinie River_Selke mit dem Polygon schneiden, Vector > Geoprocessing Tools > Clip





Prozessierung der Randgeometrien
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 Die Anzahl der Stützpunkte des Vektorlayers River_Selke ist zu groß(Δx=25m), Das Plugin 

Qchainage wird verwendet um den Stützpunktabstand auf 250m zu verändern

 Stützpunkte entfernen die direkt auf dem Rand Domain_Bound liegen. 

 Points to path anwenden um eine Polylinie zu erzeugen und dann das Feature als Shapefile 

speichern, z.b: PL_Selke_250.shp



Meshgenerierung Gmsh-QGIS Plugin
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 Grundlagen siehe Schadstoffhydrologie V8 

(letzte Woche)

 Gmsh ist ein sehr mächtiger Netzgenerator für 1D 

bis 3D Netze und unterstützt verschiedene 

Elementformen, Hybride Netze etc

 Es gibt ein QGIS Plugin zur Erzeugung von 2D 

Dreiecksnetzen : 

https://github.com/sebbelese/qgis-gmsh

 Gmsh muss dabei auf ihrem Computer installiert 

sein: http://gmsh.info/

 Wir werden 3 verschiedene FEM-Netze erstellen 

und in ihrer Qualität beurteilen

Gmsh.info

https://github.com/sebbelese/qgis-gmsh
http://gmsh.info/


Netzgenerierung Gmsh-QGIS Plugin
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 Seien Sie sich bewusst, dass es viele Möglichkeiten gibt, das Netz in QGIS zu erstellen und sie alle 

zu unterschiedlichen Ergebnissen führen!

 Sie können z.B. in der Auflösung variieren, was sich auf die Bearbeitungszeit für das Netz selbst, 

aber auch auf die Laufzeit und Stabilität des numerischen Prozessmodells auswirken kann  

 Bedenken Sie was Sie benötigen und sparen Sie wertvolle Ressourcen! 

 Wir werden drei verschiedene FEM-Netze erstellen und in ihrer Qualität beurteilen



Gmsh Meshing
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 Laden sie von den Inputdaten zusätzlich den Layer PL_Lakes_Cutted_250.shp in QGIS

 Dieses Vektorlayer beschreibt die Umrisse der Seen, jedoch fehlt je ein Linienelement 

 Dadurch keine geschlossenen inneren Oberflächen im Netz Keine Löcher im FEM Netz



Gmsh Meshing I
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 Öffnen sie Gmsh in QGIS durch klicken auf Plugins > Gmsh > Generate a Gmsh geometry file

 Auswahl von Domain_Bound as Mesh Boundary and PL_Selke, PL_Lakes_Cutted_250, 

Groundwater_wells as „forced line and points“ innerhalb des zu vernetzenden Gebiets

 Datei als Mesh1.geo speichern



Gmsh Geo File
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 Warnung: Falls eine Fehlermeldung bei der Generierung der 

*.geo Datei ensteht müssen die entsprechenden Linienzüge

zu einem Multilinestring umgewandelt werden 

 „Promote to multipart“

 Die *.geo Datei definiert  die Geometrien zur 

Netzgenerierung

 In der *geo Datei können Geometrien nicht zur explizit 

sondern auch über Funktionen definiert werden wie: 



Gmsh Netzgenerierung
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 Öffnet sich das eigentliche 

Vernetzungsdialogfenster 

 Suchen Sie die ausführbare Datei Gmsh in dem 

Verzeichnis, in das Sie die Gmsh-Software 

heruntergeladen haben (falls dieses leer ist)

 Wählen Sie Frontal als Vernetzungsalgorithmus 

und klicken Sie auf Mesh (Details siehe 

http://gmsh.info/#Documentation)

http://gmsh.info/#Documentation


Gmsh Netzgenerierung

22www.ufz.de

 Wenn die Vernetzung abgeschlossen ist, klicken 

Sie auf Netzdatei laden 

 Wählen Sie im neuen Fenster GK4 als Projektion 

und konvertieren Sie das Netz 

 Verschieben Sie den neuen Layer nach oben, um 

ihn richtig zu sehen 

 Exportieren Sie den Layer als Shapefile/shp

 Herzlichen Glückwunsch, Ihr erstes Mesh ist 

fertig. Weiter geht's!



Gmsh Netzqualität
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 FEM Elemente sind verzerrt wenn komplexe 

geometrische Formen vernetzt werden.

 Jedes Element ist so konzipiert, dass es innerhalb 

eines bestimmten Bereichs der Formverzerrung 

ordnungsgemäß funktioniert. 

 Ideale Form 2D Dreieckselements ist ein 

gleichseitiges Dreieck bzw ein Quadrat

 Mesh Qualität kann über verschiedene Parameter 

bewertet werden wie „Seitenverhältnis, Skewness, 

Warping, Parallel deviation, Maximum corner angle, 

Jacobian and Orthogonal Quality“

 Z.B wirken sich <<1 Seitenverhältnisse nachteilig 

auf die Konvergenz von Finite-Elemente-Lösungen 

aus.

 Seitenverhältnis im OGS Data Explorer



Gmsh Netzqualität
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 Die Auflösung des generierten Dreiecksnetz 

verringert sich in Abhängigkeit der Entfernung der 

geometrischen Entitäten zueinander

 Der Vernetzungsalgorithmus setzt zwischen zwei 

Stützpunkte der Geometrie 2 Elemente -

>Verdopplung der Auflösung

 Sehr hohe Netzauflösungen im gesamten Bereich 

Selke/Seen möglicherweise unnötig und 

verlangsamen das Modell

 -> Reduzierung der Elementanzahl durch 

Einführung einer hochaufgelösten Pufferzone 

entlang der Geometrien



Gmsh Netz 2
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 Vereinigen der 2 PL Layer (PL_Selke, 

PL_Lakes_Cutted_250) durch klicken auf:

Vector > Data Management Tools > Merge 

Vector Layers, GK4 als CRS auswählen

 In der Toolbox die Buffer Funktion auswählen

 Auswahl des vereinigten Layers als Eingabe, 

radius auf 500 setzen und Ergebnis speichern

500m Buffer 



Gmsh Netz 2
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 Einzelne Features des Mulitpolygon 

Layer umfassen beidseitigen Abstand 

von 500 um die Polylinien herum

 Dieser Bereich kann als Zone mit einer 

höheren Auflösung in Gmsh definiert 

werden

 Dazu muss das Polygonlayer in 

Rasterlayer überführt werden

 Klicken auf Raster > Conversion > 

Rasterize

500m Buffer 



Gmsh Netz 2
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 Deaktivieren des „no data value“ in den Layer 

Eigenschaften

 250 m in der Puffer zone, 500m 

außerhalb



Gmsh Netz 2
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 Klicken auf Plugins > Gmsh > Generate a Gmsh 

geometry file

 Domain_Bound as Mesh Boundary auswählen

 Groundwater_wells als Forced points auswählen

 Rasterized as Mesh size layer auswählen

 *.geo Datei und das FEM Netz erstellen

Field Definition in geo file  



Gmsh Netz 2
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 Man kann deutlich die unterschiedliche Auflösung 

im Mesh sehen, gut gemacht!

 Allerdings befinden sich die Netzknoten nicht 

genau an der Stelle der Stützpunkte 

 Wahrscheinlich ist es besser, Die genaue 

Linienführung der Randbedingung mit der 

Modifikation der Netzauflösung durch die Raster-

Option zu kombinieren 

 Erstellung eines neuen Meshes notwendig



Gmsh Netz III
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 Erstellung des finalen Dreiecks FEM Netzes durch Definition einer Elementauflösung für das gesamte 

Modellierungsgebiet

 Klicken auf Vector > Geometry Tools > Lines to Polygons, Auswahl des Layers Domain_Bound und 

umbenennung des resultierenden Layers zu z.B PG_Domain_1000m

 Umwandlung in ein Raster durch Raster > Conversion > Rasterize

 Auswahl von PG_Domain_1000m als Eingabelayer und 1000 sowohl als Zellauflösung für die Raster

und 1001 für die No_Data Werte, erstelltes Raster als Mesh_Size_Raster speichern

 Im Anschluss wie im vorherigen Beispiel die geo Datei sowie das FEM Netz erstellen

 Die Layer Groundwater_wells, PL_Selke, PL_Lakes_Cutted_250.shp als “Forced Geometries” 

aktivieren und inside Mesh_Size_Raster als “Mesh size layer” auswählen



Gmsh Netz III
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 Netz III zeigt eine regelmäßige FEM Struktur im Gesamtgebiet sowie eine höhere Auflösung in dem 

interessanten Strömungsbereich zwischen den Seen und der Selke

Netz I Netz II Netz III



QGIS Gmsh Export
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 Speichern des Meshs als Shapefile



QGIS Gmsh Export
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 Als letzte Aufgabe für diese Übung konvertieren Sie die Polylinien 

(PL_Koenigsauer/Concordia/Wilsleber) in Polygone, indem Sie auf Vector > Conversion > Lines 

to Polygon klicken

 Achten Sie darauf, dass Sie die Dateien speichern und nicht nur eine temporäre Datei anlegen!

 Sie können sie z.B. PG_Koenigsauer/Concordia/Wilsleber_250 nennen

 Speichern Sie auch die Domain_boundary Polylinie als PL_domain_boundary_1000.shp

Das war's, wir sind fertig!                 

Herzlichen Glückwunsch und vielen Dank fürs Mitmachen!


